During the installation of Formspider on a 11g XE database I get 1- ORA-00922: missing or invalid option on Step 1: Installation settings for Formspider Database Components.

The log files stops with 21:09:48 INFO - Free Bytes: 102170624 21:09:48 INFO - Available space: 11808473088 21:09:48 INFO - Finished gathering available tablespace size 21:09:48 INFO - ----------------------------------

asked 20 Sep '12, 12:37

Anton's gravatar image

accept rate: 0%

Hi Anton,

I am sorry for the inconvenience. Can you please send us the log file? It has additional useful information. You can sent it to contact(AT)theformspider.com


(20 Sep '12, 12:55) Ugur Kocak ♦

Hi Anton,

What value do you give for the field "Formspider Schema Name"? Setting an invalid database schema name may cause ORA-00922 error.

alt text

(21 Sep '12, 00:53) formspider ♦♦

I left it to the default FORMSPIDER

(21 Sep '12, 00:58) Anton

Hi Anton,

At this step, Installer creates the database user in order to validate the input values. I guess you thought that but i am asking to be sure, giving invalid characters for the password also causes the error. Because passwords not quoted and installer runs the "user create script" as below:

create user  + <schemaName> +  identified by  + <schemaPassword> +  default tablespace  + <tablespace>

Could you please check the password and try to run the script with your values? Do you get the same error?

(21 Sep '12, 01:31) formspider ♦♦

If I add some " around my password it works :) And I can login to the FORMSPIDER schema with the password without the surrounding ""

(21 Sep '12, 01:42) Anton

Does the installer still fail when you give a password including just alphanumeric characters (for instance you can try FORMSPIDER ) ?

(21 Sep '12, 02:02) formspider ♦♦

After I added the double quotes around my alphanumeric password everything went OK. The same alphanumeric paswword without the double quotes resulted in the ORA-00922. And the double quotes are not part of the password.

(21 Sep '12, 02:31) Anton

Anton, when you try FORMSPIDER as password, do you get the same error?

Then what happens when you create the user with the below script?

create user FORMSPIDER identified by FORMSPIDER default tablespace USERS
(21 Sep '12, 03:08) formspider ♦♦

SQL> create user FORMSPIDER2 identified by FORMSPIDER default tablespace users;

User created.


(21 Sep '12, 03:47) Anton

So, giving the password FORMSPIDER also works in the installer, right?

(21 Sep '12, 03:51) formspider ♦♦

Yes, that works. But you have alphanumeric and alphanumeric wich starts with a numeric: create user FORMSPIDER2 identified by 1FORMSPIDER default tablespace users * ERROR at line 1: ORA-00922: missing or invalid option


Guess what I used for my password.

(21 Sep '12, 04:04) Anton
showing 5 of 11 show 6 more comments


I have opened a ticket in our bug tracking system. You will be able to set any password that database accepts. Please set an alphanumeric (which starts with an alpha character) password for now.

Thank you very much for your help and taking your time.

Kind Regards


answered 21 Sep '12, 05:17

formspider's gravatar image

formspider ♦♦
accept rate: 21%

Good morning. It looks this issue of not embedding the password in double quotes (when the pwd starts with a number etc) seems still an issue. We surely can by pass the issue by having double quotes around it, I feel, it should be done by the application.


answered 26 Feb '14, 12:14

viswapsp's gravatar image

accept rate: 11%

edited 26 Feb '14, 12:16

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 20 Sep '12, 12:37

Seen: 6,102 times

Last updated: 26 Feb '14, 12:16

© Copyright Gerger 2017