hello, we have just upgraded to 1.9 version.

When I set a application to stateful app, an tree navigation stopped to work, as when trying to open a form it just returns message: An error occurred. Please contact your system administrator

any suggestion what needs to be set, to be able to use statefull app feature?

Tomas

asked 26 Sep '15, 13:28

Tomeo's gravatar image

Tomeo
162249
accept rate: 3%

Hi Tomas,

Do you see any error messages in the Tomcat console window or error logs?

Kind Regards,
Yalim

(29 Sep '15, 14:53) Yalim ♦♦

Hi Tomas,

To use stateful sessions, the following parameters have to be set in your web.xml. Please check them and restart tomcat after changes. If the issue persists, please share error logs.

<context-param>
    <param-name>engineSchemaURL</param-name>
    <param-value>@engineSchemaURL@</param-value>
    <!--jdbc:oracle:thin:@192.168.1.122:1521:ORA10G-->
</context-param>
<context-param>
    <param-name>engineUsername</param-name>
    <param-value>@ENGINE_USERNAME@</param-value>
    <!--FORMSPIDER-->
</context-param>
<context-param>
    <param-name>enginePassword</param-name>
    <param-value>@ENGINE_PASSWORD@</param-value>
    <!--FORMSPIDER-->
</context-param>

Regards Serdar

link

answered 30 Sep '15, 04:30

Serdar's gravatar image

Serdar ♦♦
100k4
accept rate: 14%

edited 30 Sep '15, 04:33

Hello Serdar,

many thanks for your help. It solved an issue with stateful sessions.

Tomas

link

answered 04 Oct '15, 04:06

Tomeo's gravatar image

Tomeo
162249
accept rate: 3%

Should these parameters be set in Formspider web.xml - apache-tomcat-6.0.29/webapps/formspider/WEB-INF/web.xml ? Or in Tomcat configuration web.xml - apache-tomcat-6.0.29/conf/web.xml ?

When I installed Formspider 1.9 with Tomcat, the Formspider web.xml already had these lines. However, the parameter values are slightly different from what you posted above -

<param-value>@engineUsername@</param-value>

<param-value>@enginePassword@</param-value>

Or do I need to actually replace the @parameters@ with a real username and password of the Formspider Oracle user?

Please kindly advise.

Thanks, Ilia

link

answered 19 Oct '15, 21:58

Ilia%20Sazonov's gravatar image

Ilia Sazonov
120511
accept rate: 0%

edited 19 Oct '15, 22:03

Hi Ilia,

These parameters should be set in apache-tomcat-6.0.29/webapps/formspider/WEB-INF/web.xml, and you need to replace those boilerplate values with your actual database connection parameters ( URL, formspider schema name and formspider schema password ).

e.g.

<context-param>
    <param-name>engineSchemaURL</param-name>
    <param-value>jdbc:oracle:thin:@10.1.1.75:1521:ORCL</param-value>
</context-param>
<context-param>
    <param-name>engineUsername</param-name>
    <param-value>FORMSPIDER_SCHEMA_NAME</param-value>
    <!--FORMSPIDER-->
</context-param>
<context-param>
    <param-name>enginePassword</param-name>
    <param-value>FORMSPIDER_SCHEMA_PASSWORD</param-value>
    <!--FORMSPIDER-->
</context-param>

Best regards, Serdar

(20 Oct '15, 04:28) Serdar ♦♦

Thank you for the clarification, Serdar! It works!

link

answered 20 Oct '15, 14:25

Ilia%20Sazonov's gravatar image

Ilia Sazonov
120511
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1

Asked: 26 Sep '15, 13:28

Seen: 1,862 times

Last updated: 20 Oct '15, 14:25

Related questions


© Copyright Gerger 2017