Hallo,

I created an application and wanted to run it on an iPhone. I run the link in the browser on the smartphone, but all I got is a blank site, no error message. Have you any idea which could be the problem? Is there any possibility to debug and to find out what the problem is?

Regards, Lisa

asked 13 Jan '14, 07:12

Lisa's gravatar image

Lisa
1716
accept rate: 0%

Hi Lisa, Could you please send us the application? The email address is contact at theformspider dot com.

(13 Jan '14, 07:15) Yalim Gerger ♦♦

Hello Lisa,

I have imported the application you sent,however, I couldn't reproduce your problem.

I tried it in Mobile Safari and Chrome Mobile browsers as well as in Formspider Native Application. All of them worked as expected. Could you tell me your iOS version and browser version?

chrome
App in Chrome

link

answered 14 Jan '14, 05:06

Serdar's gravatar image

Serdar ♦♦
100k4
accept rate: 14%

edited 14 Jan '14, 05:19

Hello,

The iOS Version is 7.0.4 and the browser is Safari.

Regards, Lisa

link

answered 20 Jan '14, 06:40

Lisa's gravatar image

Lisa
1716
accept rate: 0%

I think I figured out what the problem is, but I don't know how to solve it right now. Maybe you have an idea.

I had a look at the website source code of the blank page in the browser at my smartphone (view-source:URL) I see that maps.google.com and maps.googleapis.com is used and that this is loaded when starting the app.

I think this is the problem, because of the network settings I'm working in. The URL of the appication I have to access is not public. This means it is only accessible in the intranet. And in this WLAN I don't have access to google. So cannot I load the applications in the internal WLAN and also not in the public WLAN (because there I cannot access the application URL). I hope you understand my problem.

I had a look at Formspider Desktop and saw that when running an application it doesn't try to connect to Google Maps.

The question is if I can prevent the loading of Google Maps when running a mobile app?

link

answered 23 Jan '14, 10:06

Lisa's gravatar image

Lisa
1716
accept rate: 0%

Hi Lisa,

This seems like a bug. I created a ticket in our bug tracking system for this issue.

As a workaround, you might want try to find the main.jsp file under the mobile folder in the Formspider middle tier installation and remove any references to Google in this file. I haven't tested if this workaround works but it might.

Kind Regards,
Yalim

(23 Jan '14, 10:13) Yalim Gerger ♦♦

Hi Yalim,

thank you for your answer. I had a look in the main.jsp file, but there is no reference to Google. Have I looked in a wrong file? The only file which I found so far with references to Google is the main.html where Google Maps script is included. Removing this inclusion leads to a blank page even when executing the app on the computer.

Kind Regards, Lisa

(27 Jan '14, 03:00) Lisa

I removed all references to Google in main.html. It is not sufficient. When running the application there is a blank page and I examined the page with firebug. It says:

ReferenceError: google is not defined in fs-mobile.js (Zeile 260)

(27 Jan '14, 07:28) Lisa

Oh well..It was worth a try. Until we fix this, your only solution is work in a network where google maps is not blocked.

(27 Jan '14, 07:30) Yalim Gerger ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×23
×19

Asked: 13 Jan '14, 07:12

Seen: 1,459 times

Last updated: 27 Jan '14, 07:30


© Copyright Gerger 2017