Hi

I had been working without issue in my local and I went formspider the error mentioned in An Error ocurred browser. Please contact your system administrator. In the tomcat window appears. java.lang.NullPointerException

What can it be?

asked 17 Jul '13, 14:55

Carlos%20Mayorga's gravatar image

Carlos Mayorga
137
accept rate: 0%

Hi Carlos,

Is this happening in Formspider Online (Cloud) or in your local installation?

(17 Jul '13, 14:57) Yalim ♦♦

Hi Carlos,

The NullPointerExceptions generally tell us that Formspider Middletier isn't able to get a connection from Oracle Database. There may be several reasons for that:

  1. web.xml file - inside Tomcat/webapps/fs-1.x.x/WEB-INF/ directory - is missing or corrupted.
  2. If you install FS with FSInstaller, context.xml file - inside Tomcat/webapps/fs-1.x.x/META-INF/ directory - is missing or corrupted.
  3. If you install manually and put your database connections under global context file, context.xml file - inside Tomcat/conf/ directory - is missing or corrupted.
  4. ojdbc driver JAR file is not suitable for your database and/or JAVA version.

To solve this connection problem:

#1. Stop Tomcat.

#2. Make sure that there are similar lines in your web.xml like those below.

  <context-param>
    <param-name>engineJdbcName</param-name>
    <param-value>jdbc/formspider_ds</param-value>
  </context-param>

Please keep in mind this param-value of your web.xml.

#3. If there is a context.xml file inside Tomcat/webapps/fs-1.3.0/META-INF/ directory, make sure that there are similar lines in this context.xml like those below.

 <Resource name="jdbc/formspider_ds" 
                  auth="Container"
                  type="oracle.jdbc.pool.OracleDataSource" 
                  driverClassName="oracle.jdbc.OracleDriver"
                  url="jdbc:oracle:thin:@DB_URL:DB_PORT:DB_SID"
                  user="FORMSPIDER_SHEMA" 
                  password="FORMSPIDER_SHEMA_PASSWORD" 
                  factory="oracle.jdbc.pool.OracleDataSourceFactory"
                  scope="Shareable"
                  connectionCacheName="formspider_ds_cache0"
                  connectionCachingEnabled="true"
                  connectionCacheProperties="{MinLimit=5, InitialLimit=5, ValidateConnection=true, MaxLimit=15, InactivityTimeout=900, AbandonedConnectionTimeout=900, PropertyCheckInterval=45, ConnectionWaitTimeout=60}" />

Please fill database url, port, sid and formspider schema name and password with yours; and make sure that name parameter is the same as the param-value that you have kept in mind from #2.

#4. If there is not a context.xml file inside Tomcat/webapps/fs-1.3.0/META-INF/ directory, make sure that there are similar lines in the context.xml inside Tomcat/conf/ directory like those below.

   <Resource name="jdbc/formspider_ds" 
                  auth="Container"
                  type="oracle.jdbc.pool.OracleDataSource" 
                  driverClassName="oracle.jdbc.OracleDriver"
                  url="jdbc:oracle:thin:@DB_URL:DB_PORT:DB_SID"
                  user="FORMSPIDER_SHEMA" 
                  password="FORMSPIDER_SHEMA_PASSWORD" 
                  factory="oracle.jdbc.pool.OracleDataSourceFactory"
                  scope="Shareable"
                  connectionCacheName="formspider_ds_cache0"
                  connectionCachingEnabled="true"
                  connectionCacheProperties="{MinLimit=5, InitialLimit=5, ValidateConnection=true, MaxLimit=15, InactivityTimeout=900, AbandonedConnectionTimeout=900, PropertyCheckInterval=45, ConnectionWaitTimeout=60}" />

Please fill database url, port, sid and formspider schema name and password with yours; and make sure that name parameter is the same as the param-value that you have kept in mind from #2.

#5. After you are sure about the above, and still getting NullPointerException. You should replace your ojdbc dirver JAR file with another.

   If there is a JAR file named ojdbc14.jar inside Tomcat/webapps/fs-1.3.0/WEB-INF/libs, replace it with ojdbc5.jar.
   If there is a JAR file named ojdbc5.jar inside Tomcat/webapps/fs-1.3.0/WEB-INF/libs, replace it with ojdbc14.jar.

I hope this helps,

Best Regards,
Serdar Gokcen,

link

answered 18 Jul '13, 09:17

asdr's gravatar image

asdr ♦
9949
accept rate: 8%

edited 18 Jul '13, 09:18

Hi

In local installation. The strange thing happened to me on 2 different local installations.

(18 Jul '13, 08:44) Carlos Mayorga

Hi

Indeed the problem was presented by changes in the ip of the computer, which caused disconnect to database.

Thank you very much for the cooperation.

link

answered 18 Jul '13, 14:18

Carlos%20Mayorga's gravatar image

Carlos Mayorga
137
accept rate: 0%

It's good to hear you've found the cause of your problem.

(18 Jul '13, 15:22) asdr ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×44

Asked: 17 Jul '13, 14:55

Seen: 2,472 times

Last updated: 18 Jul '13, 15:22


© Copyright Gerger 2017