Hi, I created a simple report in iReport 5.1.0 and have done all configuration that in http://theformspider.com/learningcenter/tutorial-16-integrating-jasperreports-into-formspider-using-htmlrenderer-component/

But then I open link [App Server]/formspider/jasperreportsservlet?rep_name=report1&destination=display it gives me Internal Server Error If I open link [App Server]/formspider/jasperreportsservlet?rep_name=report1 it gives "Welcome.. Please select destination: "download" or "display""

What I doing wrong when add to link "&destination=display" ?

Thanks.

asked 09 Jul '13, 05:58

Emil's gravatar image

Emil
451217
accept rate: 0%


Hi Emil,

Formspider installation has suitable 4.6.0 libraries to run report correctly. If you use another iReport designer like 5.1.0, you need to replace existing libraries with appropriate ones.

You may find existing libraries under Formspider middle-tier installation: "/webapps/formspider/WEB-INF/lib".

And download new libraries from: http://sourceforge.net/projects/jasperreports/files/jasperreports/JasperReports%205.1.0/

You need to replace following libraries:

  • jasperreports-4.6.0.jar
  • jasperreports-applet-4.6.0.jar
  • jasperreports-fonts-4.6.0.jar
  • jasperreports-javaflow-4.6.0.jar

Regards, Samet

link

answered 09 Jul '13, 06:22

Samet%20Basaran's gravatar image

Samet Basaran
1372
accept rate: 24%

Thanks for answer but problem not solved yet. Previous link shows the same error.

(09 Jul '13, 07:00) Emil

I guess, you keep getting "internal server error" from the following url, right? [App Server]/formspider/jasperreportsservlet?rep_name=report1&destination=display

did you deleted old 4.6.0 libraries from your tomcat installation ? did you restarted your tomcat installation ?

(09 Jul '13, 07:06) Samet Basaran

Yes, i deleted old files and restart tomcat. This not worked, then I restarted server, and jasperreport still not worked...

(09 Jul '13, 07:19) Emil

Two more questions: did you updated web.xml file to set connection parameters and directory of the file? Is there any bindvar in your query?

(09 Jul '13, 07:25) Samet Basaran

Here is web.xml changes: <context-param> <param-name>databaseURL</param-name> <param-value>jdbc:oracle:thin:@192.168.1.83:1521:XE</param-value> <context-param> <param-name>databaseUsername</param-name> <param-value>odeme</param-value> <context-param> <param-name>databasePassword</param-name> <param-value>pass</param-value> <context-param> <param-name>fileDirectory</param-name> <param-value>c:\reports\</param-value>

There is no bindvar in query.

just now I installer iReport 4.6.0 , import settings from 5.1.0 and build report. After all this error is Internal Server Error.

Before that I copy old .jar file to lib.

(09 Jul '13, 07:31) Emil

The problem is not related with 5.1.0 or 4.6.0 version. If you compile your report1.jasper file with one specifiec version, then libraries must be in same version.

We miss another step from tutorial in your example. I may recommend you that try to finish the tutorial step by step. And then try new example. If you cannot complete tutorial successfully I may need to check your installation.

One more think, did you put your report1.jasper file under c:\reports\ directory? And can you see any error on tomcat window?

(09 Jul '13, 07:43) Samet Basaran

there is no error in tomcat window and report1.jasper is in c:\reports\ Now will try to finish tuutorial..

(09 Jul '13, 07:50) Emil

please help, I finished tutorial and this gives me browser when I try to download report: This webpage is not found No webpage was found for the web address: http://192.168.1.83:8888/formspider/jasperreportsservlet?rep_name=employeesOfDepartments&destination=download&dep_id=50 Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found.

(09 Jul '13, 08:30) Emil

is there any problem on display option?

could you check your rights(create/delete file) on C:\reports directory.

(09 Jul '13, 08:40) Samet Basaran

display option gives internal server error. I check right on that folder - Full Control by Everyone, Authenticated Users, SYSTEM, Administrators, Users

(09 Jul '13, 08:50) Emil

first we need to solve display option problem. I think you have finished the tutorial and you get same error. which Formspider version do you use? And could send me(samet.basaran@gerger.co) the report1.jasper file do you use?

(09 Jul '13, 08:56) Samet Basaran

With employeesOfDepartments.jasper gives same error. I downloaded it from tutorial. I have send to you mail.

(09 Jul '13, 09:07) Emil
showing 5 of 12 show 7 more comments

Hi, we have the same problem, but we installed Formspider and Jasperreport Server 5.1.0 on Linux. The report is both the one downloaded from the tutorial and one developed with iReport 5.1.0. We changed the file web.xml (the one under the path /var/lib/tomcat6/webapps/formspider/WEB-INF) to set the parameters as in the tutorial and in these comments. We also changed the libraries of Jasperreport Server as shown in the first reply above. But it doesn't work. Any more suggestions? Thank you in advance S&S

link

answered 18 Jul '13, 06:31

Arsinform's gravatar image

Arsinform
1116
accept rate: 0%

Hi, Could you check the log file(its name must be like localhost.2013-07-18.log) under tomcat6/logs/ folder and get some details about your error?

Samet

(18 Jul '13, 07:51) Samet Basaran

Hi Samet, this is what the page on the browser shows:

Error occured while displaying report net.sf.jasperreports.engine.fill.JRExpressionEvalException: Error evaluating expression : Source text : new java.lang.Integer(1) net.sf.jasperreports.engine.fill.JREvaluator.evaluateEstimated(JREvaluator.java:267) net.sf.jasperreports.engine.fill.JRCalculator.evaluateEstimated(JRCalculator.java:582) net.sf.jasperreports.engine.fill.JRCalculator.estimateVariables(JRCalculator.java:181) net.sf.jasperreports.engine.fill.JRFillDataset.next(JRFillDataset.java:1234) net.sf.jasperreports.engine.fill.JRFillDataset.next(JRFillDataset.java:1208) net.sf.jasperreports.engine.fill.JRBaseFiller.next(JRBaseFiller.java:1554) net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReport(JRVerticalFiller.java:149) net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:909) net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:822) net.sf.jasperreports.engine.fill.JRFiller.fill(JRFiller.java:61) net.sf.jasperreports.engine.JasperFillManager.fill(JasperFillManager.java:446) net.sf.jasperreports.engine.JasperFillManager.fill(JasperFillManager.java:407)

(19 Jul '13, 05:06) Arsinform

net.sf.jasperreports.engine.JasperRunManager.runToPdfStream(JasperRunManager.java:201) net.sf.jasperreports.engine.JasperRunManager.runReportToPdfStream(JasperRunManager.java:720) co.gerger.bdf.view.JasperReportsServlet.doGet(JasperReportsServlet.java:106) javax.servlet.http.HttpServlet.service(HttpServlet.java:617) javax.servlet.http.HttpServlet.service(HttpServlet.java:717) org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) co.gerger.filters.GZIPFilter.doFilter(GZIPFilter.java:48) org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:465)

(19 Jul '13, 05:06) Arsinform

org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298) org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857) org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588) org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489) java.lang.Thread.run(Thread.java:724)

(19 Jul '13, 05:06) Arsinform

Thank you very much

(19 Jul '13, 05:07) Arsinform

Hi,

Thank you very much for details. I think the problem is related with the JasperReports 5.1.0 release. Could you use iReport 4.6.0 and its related libraries?

Regards, Samet

(19 Jul '13, 05:24) Samet Basaran
showing 5 of 6 show 1 more comments

I cant solve this problem and just tried the same report to build with iReport 4.6.0 on another OS (new instalation) and it works fine. I figure that problem was not in FS or iReport, because same report with same iReport version and same FS version worked fine on another, new installer, clear OS. I tried on Lubuntu, Win7 and WinXP. On new instalation all works well.

link

answered 18 Jul '13, 12:51

Emil's gravatar image

Emil
451217
accept rate: 0%

Hi Emil,

You need to be able to run your report properly with iReport 4.6.0 and related libraries without new OS installation. But it is great to see it works fine for you.

Regards, Samet

(19 Jul '13, 05:32) Samet Basaran
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2

Asked: 09 Jul '13, 05:58

Seen: 2,359 times

Last updated: 19 Jul '13, 05:32


© Copyright Gerger 2017